Error: browser login fails when clicking a ribbon button

Error: browser login fails when clicking a ribbon button

Issue

When clicking a button in the KitConnect ribbon for the first time after starting Revit, the browser pops open to authenticate the user. However, instead of a login screen, the user sees something similar to the following (the error may look different, depending on your browser):

Causes

There are three likely causes:
  1. Your computer has no internet connection - an internet connection is required for KitConnect to work properly.
  2. Another application is using port 3006, which KitConnect uses to authenticate.  It's been found that Windows 10's own Hyper-V application occasionally uses this port, but it could be another application as well.
  3. A firewall on your network is blocking the connection.

Solution - Cause #2

If you are certain that your internet connection is stable, then follow these steps to see if port 3006 is being used by another service:
  1. Type cmd in the start menu search bar
  2. Right-click the "Command Prompt" application and select Run as Administrator
  3. Type (or copy/paste) the following command:
    netsh int ipv4 show excludedportrange protocol=tcp
  4. If any of the ranges that appear include 3006, then continue to the next step.  If not, then there's something else going on - please contact KitConnect support.
  5. Disable Hyper-V - from the same Command Prompt, copy and paste the following
    dism.exe /Online /Disable-Feature:Microsoft-Hyper-V
  6. Restart your computer
  7. After restart, reserve the port so Hyper-V doesn't try and take it it back.  Re-open the command prompt as in Step 2, and paste the following:
    netsh int ipv4 add excludedportrange protocol=tcp startport=3006 numberofports=1 store=persistent
  8. Re-enable Hyper-V - from the same command Prompt, copy and paste the following
    dism.exe /Online /Enable-Feature:Microsoft-Hyper-V
  9. After restart happens, this issue should be fixed permanently.

Solution - Cause #3

Ask your IT Administrator to whitelist the following URLs in your firewall:
  1. *.kitconnect.io
  2. *.kit-connect.com
  3. developer.api.autodesk.com

    • Related Articles

    • Current Release Notes

      KitConnect for Revit v3.4.0 - Project Design Efficiency Several quality-of-life improvements for project designers in KitConnect for Revit v3.4.0 offer significant time-savings when inserting modules, browsing for content, and getting updated ...
    • II - Create and Enable Projects

      The user must be BIM360 Account Administrator to perform the following steps. 1. Create a KitConnect account Navigate to app.kit-connect.com Create a new account with us, using your BIM360 email. 2. Create or enable a project for use with KitConnect ...
    • Enterprise Libraries

      The following view is only accessible to Account Administrators. The Account Admin role is determined by the associated BIM 360 account settings. KitConnect enables users to use Enterprise Libraries for their published content in addition to Project ...